W4L Fehlersuche / FAQ

Allgemeines

Funktioniert das Plugin mit LoxBerry 2.0?

Ja, insbesondere wird es bereits unter LoxBerry 2.x entwickelt und getestet. Im Hauptartikel ganz oben steht die Versionsnummer von LoxBerry, die mindestens erforderlich ist ("Min. LB Version"). Das Plugin funktioniert mit dieser, und jeder höheren Version.

Das Plugin funktioniert seit dem Update auf Loxone Config 11 nicht mehr

Im Forum gibt es unzählige Beiträge, die bestätigen, dass auch nach dem Loxone-Update alles funktioniert. Demnach liegt das Problem wohl eher bei deiner Installation. Schau dir die weiteren Lösungsvorschläge an.

Eingehende Werte von den Wetterdiensten

Kann ich nachsehen, von welcher Wetterstation die Daten des Wetterdienstes stammen?

In der Regel nein. Schau dir die Webseiten der Wetteranbieter an, ob du dort eine Liste oder Grafik findest.

In der Nähe von Städten werden meist die Daten der Flughäfen herangezogen. 

Ich habe eben einen API-Key des Wetterdienstes angefordert und eingetragen, aber es geht noch immer nicht

Die Freischaltung des API-Keys kann je nach Wetterdienst auch 15 Minuten oder länger dauern. Lies dir in der Zwischenzeit die Anleitung von Weather4Lox durch, und probier es später nochmal.

Bei einem oder mehreren Werten wird "-9999" angezeigt

-9999 wird aktiv vom Plugin an den Miniserver gesendet (bzw. dem Emulator bereitgestellt), wenn der gewählte Wetterdienst diesen Wert nicht anbietet. Es kann auch sein, dass der gewählte Wetterdienst nur in deiner Region diesen Wert nicht bereitstellt (weil z.B. die vom Wetterdienst verwendeten Wetterstationen in deiner Nähe diese Messdaten nicht bereitstellen).

Manche Dienste bieten gewisse Daten nur gegen Bezahlung. Bei den Webseiten der Dienste ist oft eine Übersicht, was alles gratis ist, und was gebührenpflichtig.

Bitte schau in die Liste im Hauptartikel, welcher Wetterdienst welche Werte anbietet, und wechsle ggf. den Wetterdienst.

Wetterdaten per UDP

Es kommen keine Werte

  • Prüfe in der Loxone Config im UDP Monitor - siehst du dort Daten? → Das Plugin arbeitet korrekt
  • Prüfe den Virtuellen UDP-Eingang - ist der Port korrekt eingestellt? 
  • Hast du nach dem Anlegen der Eingänge sicher auf "Im Miniserver speichern" gedrückt?

Wetter-Emulator

In der Loxone App wird kein Wetter-Symbol angezeigt

Du musst in der Loxone Config explizit den Wetterservice aktivieren. Nach Speichern und Restart des Miniservers erscheint das Wetter-Symbol links oben.

Wenn das nicht hilft:

  • In der Loxone App auf die Minserver-Einstellungen, Wetter. Sollte dann Wetter-Werbeslides kommen, diese durchgehen und nochmal prüfen, ob das Wetter-Icon jetzt angezeigt wird.

Wenn ich das Wetter-Symbol klicke, erscheint Loxone Werbung für den Wetterservice

Das ist in der Regel ein Problem mit deiner Netzwerk-Konfiguration am Miniserver.

Technisch hat der Wetter-Emulator zwei Funktionen:

  1. Er stellt die Wetterdaten in dem Format bereit, wie ihn auch das Original-Loxone Wetterservice anbieten würde.
  2. Er fängt Webanfragen vom Miniserver an das Loxone Wetterservice ab, und leitet diese zum Wetter-Emulator.

Damit Punkt 2 funktioniert, müssen in der Netzwerkkonfiguration des Miniservers die DNS-Adressen ("DNS-Server 1", "DNS-Server 2") mit der IP-Adresse des LoxBerry befüllt werden (2 mal die gleiche IP). 

Immer, wenn der Miniserver ins Internet kommuniziert, kommt die Anfrage zum LoxBerry Wetter-Emulator (konkret zum DNS-Server dnsmasq am LoxBerry). Wenn es eine Wetteranfrage ist, beantwortet das Plugin die Anfrage. Wenn nicht, wird die Internetanfrage an den Router weitergeleitet.

Wenn das alles korrekt eingestellt ist, kann es helfen, einmal den Miniserver neu zu starten.

Gewisse Werte werden auf der Plugin-Webseite korrekt angezeigt, aber in der App anders oder 0

Bei den Wetter-Sensordaten in der Loxone Config kann man ein Häckchen "Wert durch Logik definiert" setzen. Damit musst du selbst in der Loxone Config diesen Wert befüllen - die Daten vom Emulator werden vom Miniserver ignoriert. Deaktiviere diese Checkbox, damit die Daten vom Emulator verwendet werden.

"Sonnenschein" funktioniert nicht (mehr)

Siehe eins vorher: Dein Wetterdienst oder die Wetterstation in deiner Nähe bietet den Wert nicht an. 

Die Wetter-Webseite des Plugins zeigt andere Werte an als die Loxone App

Die Wetter-Webseite des Plugins wird in dem Takt aktualisiert, den du im Plugin eingestellt hast (alle 3 Minuten, 10 Minuten usw.). Der Loxone Miniserver hingegen holt die Wetterdaten nur einmal pro Stunde ab. Das ist von Loxone im Miniserver fest programmiert und lässt sich nicht umstellen.

Ich habe extra das dnsmasq Plugin installiert, aber der Emulator funktioniert nicht

Ja, weil du - wie's im Hauptartikel steht - explizit das dnsmasq Plugin NICHT installieren darfst, damit das Plugin die Konfiguration durchführen kann.

Wenn du das dnsmasq Plugin installiert hast, weil du es brauchst, musst du dnsmasq auch selbst konfigurieren. Im Hauptartikel steht der Eintrag, den du brauchst.

Es kommen keine Daten von meinem Miniserver zum Plugin

Prüfen, ob der Baustein (zB Merker) auch die entsprechende Berechtigung hat.

Kontrollieren kann man das am Besten in dem man das Loglevel auf Debug stellt und sich das Log "Grabber_loxone" anschaut.

Keine der genannten Lösungen hat geholfen

Bevor du ins Forum schreibst:

  • Stelle den Loglevel des Plugins auf DEBUG
  • Funktioniert die Wetter-Webseite im Plugin? (Screenshot)
  • Welche Daten kommen per UDP an? (Screenshot)
  • Was genau funktioniert nicht? (Screenshot)
  • Lade das aktuellste Logfile aus dem Log Manager des Weather4Loxone Plugins herunter.
  • Erstelle mit all den Daten (alle Screenshots, Logfiles) eine Frage im loxforum Thread.
  • Stelle danach den Loglevel zurück auf "Fehler".